Deleted Artifacts are sometimes accessible by Claude for Work teammates

Incident Report for Anthropic

Resolved

Artifacts shared within a Claude for Work organization are now deleted when the chat which originated the Artifact is deleted. All affected artifacts are in the process of being corrected.
Posted Mar 14, 2025 - 16:09 PDT

Investigating

We are currently investigating an issue where some Artifacts that have been shared within a Claude for Work organization may remain accessible when the chat which originated the Artifact is deleted. All Artifacts remain inaccessible outside of the Claude for Work organization.
Posted Mar 12, 2025 - 16:10 PDT
This incident affected: claude.ai.