Team plan organizations unable to add more members

Incident Report for Anthropic

Resolved

We have resolved the underlying issue and Team plan organizations should now be able to add more members.
Posted Aug 19, 2025 - 18:01 UTC

Update

The fix will be rolled out in the next few hours. We will provide another update when it has been fully deployed.
Posted Aug 19, 2025 - 13:39 UTC

Identified

We have identified an issue that, since August 18, has caused Team plan organizations to be unable to add more members. We are working on a fix.
Posted Aug 19, 2025 - 12:35 UTC
This incident affected: claude.ai.