Between 21:00 UTC on October 28 through 04:15 UTC on October 30, API calls invoking tool use intermittently failed to include all parameters, including required parameters. This issue primarily affected requests to claude-3-5-sonnet-20241022 and claude-3-haiku-20240307, and has now been resolved.
Posted Oct 29, 2024 - 21:15 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 29, 2024 - 18:43 PDT
Update
We have identified broader impact to requests invoking tool use, which is resulting in some arguments failing to include some arguments, even when required. We are actively working to resolve this issue, and will provide additional updates soon.
Posted Oct 29, 2024 - 17:47 PDT
Update
We are continuing to investigate intermittent failures to invoke tools in the computer use beta.
Posted Oct 29, 2024 - 13:16 PDT
Investigating
We are currently investigating an issue resulting in incorrect tool calls when using the computer use beta. We will provide updates as soon as possible.